Problem with web server

Lifeguard™ - Reports key tank parameters
Lobrien020
Posts: 1
Joined: Thu Jun 05, 2014 8:28 pm
How many years have you been in the hobby?: 0

Problem with web server

Postby Lobrien020 » Thu Jun 05, 2014 9:38 pm

I have been using the Digital Aqautics Lifeguard system with firmware version 2.01 for about 1 week now and up until today everything seemed to be working alright.

This afternoon I tried to load the web interface one of two things will happen:
1. After a few minutes the browser will prompt for the log in credentials which I enter and after a few more minutes the page attempts to load with only some of the objects load.
2. In the other scenario the page simply does prompt for a log in and does not load at all and I receive a page not found error.
I have tested this with Chrome v35 and Internet Explorer 10 (with and without compatibility mode) on three separate computers (Windows 7 professional, Windows 8.1, and Windows Server 2008 R2) as well as Chrome and Safari on the iPhone. They all produce a mixture of the two scenarios above.

I have it wired directly into a GB switch with a static IP that is reserved and set outside of my DHCP range to avoid conflicts. I have tried the following troubleshooting steps so far:
1. Remove power from the unit for about 5 minutes and then restore power.
2. Restarted the computers and devices I am using to access the device.
3. Cleared all temporary files (Windows TEMP directory and Browser Temporary files).
4. Cleared cookie and saved password data related to the device IP address.
5. Renewed IP address on computer and flushed the DNS.
6. Removed power from router (DHCP server) for about 5 minutes as well as power from the Lifeguard device and restored the router power, once it was back up I restored power to the Lifeguard device as well as rebooted the computer I am accessing it from.
7. I tried multiple network cables all of which I know to be in working order and tested with a desktop.
8. Also while testing different network cables I tested different ports on the switch.

On the device I have a solid green light, a blinking blue light, and network activity lights on both end of the network cable (device and the switch).

The only thing left I can think of is to perform a factory reset on the device. I have not done that yet because it will require I calibrate the Ph sensor again and would rather not since I only have a finite amount of calibration fluid. My other concern with performing a factory reset on the device is if that does resolve the issue I would hope that this is not the solution every time this occurs. Another option I have not tested yet is to bypass the switch and connect to an open port directly on the router. This option will have to wait until I can take the network down and to free up a port on that device. If either of these result in a solution I will update this post at that time.

Attached are screenshots of the various results I have seen when connecting to the device. Based on the browser results it does not seem to be limited to a specific browser or O/S. As I said initially everything was working or the first few days. I did notice a few times the page was slow to load but it always seemed to load at some point and function properly. I work in the IT field so I am don't mind troubleshooting this and completely understand that devices like this that run an internal web server sometimes need to be rebooted from time to time but I am out of ideas here.

Any help you can offer would be greatly appreciated.

Thank you,
Liam
You do not have the required permissions to view the files attached to this post.

User avatar
DA_Eric
Posts: 407
Joined: Thu Dec 19, 2013 10:57 am
How many years have you been in the hobby?: 20

Re: Problem with web server

Postby DA_Eric » Mon Jun 09, 2014 10:20 am

problem is resolved. There was an error in a text file that the lifeguard unit checks for updates.


Return to “Monitors”

Who is online

Users browsing this forum: No registered users and 1 guest