Warranty/ customer support

Advanced aquarium controller
wtbuck12
Posts: 8
Joined: Thu Feb 04, 2010 3:35 pm
How many years have you been in the hobby?: 0

Warranty/ customer support

Postby wtbuck12 » Tue Dec 26, 2017 10:34 am

I have a Reefkeeper Elite system that is nine months old and the temperature reading isn't working. I came home last weekend and the display was reading 179 degrees but the water temp was actually 75.7 degrees. Tried to recalibrate and the display showed 75.7 but never changed. I tried a new probe but still not working. Does anyone have a contact number for customer support or warranty department?

User avatar
n2585722
Posts: 6168
Joined: Mon Sep 08, 2008 5:54 am
How many years have you been in the hobby?: 30

Re: Warranty/ customer support

Postby n2585722 » Tue Dec 26, 2017 10:53 am

I think you have to send them an email. What module do you have it plugged into? You may need to power it down and back on.
thanks,
Danny

wtbuck12
Posts: 8
Joined: Thu Feb 04, 2010 3:35 pm
How many years have you been in the hobby?: 0

Re: Warranty/ customer support

Postby wtbuck12 » Tue Dec 26, 2017 1:18 pm

It is pluged into an SLX module. I will try rebooting and see what happens, thanks.

wtbuck12
Posts: 8
Joined: Thu Feb 04, 2010 3:35 pm
How many years have you been in the hobby?: 0

Re: Warranty/ customer support

Postby wtbuck12 » Tue Dec 26, 2017 3:29 pm

Rebooting the system did not help. The display is showing the same temp as when I recalibrated even though the actual temp has gone up 1.2 degrees.

User avatar
n2585722
Posts: 6168
Joined: Mon Sep 08, 2008 5:54 am
How many years have you been in the hobby?: 30

Re: Warranty/ customer support

Postby n2585722 » Tue Dec 26, 2017 6:12 pm

You can try and reset the temp port to factory defaults. Note this is not the same as reseting the head unit to factory defaults and requires using myReef with the system powered up and running. Select the SLX module in the tree on the left in my reef then select the temp port. There should be a way to reset the port to factory defaults. It has been a few years since I used myReef with the RKE system. Hope this helps.
thanks,
Danny

wtbuck12
Posts: 8
Joined: Thu Feb 04, 2010 3:35 pm
How many years have you been in the hobby?: 0

Re: Warranty/ customer support

Postby wtbuck12 » Wed Dec 27, 2017 1:41 pm

Tried that already, display showed 9.1 degrees. Recalibrated probe to tank temp of 78.5 degrees, display showed 78.5 but never moved even when water temp rose to 79.8 degrees, my set temp on the heaters.

wtbuck12
Posts: 8
Joined: Thu Feb 04, 2010 3:35 pm
How many years have you been in the hobby?: 0

Re: Warranty/ customer support

Postby wtbuck12 » Thu Jan 11, 2018 7:41 pm

Terrible customer service. Left several voice mails and sent email requesting a returned phone call, waited two weeks and finally gave up. I finally got an email after two weeks asking the same questions I had already tried. My system is still not working correctly and I have to say after using the RKE system for close to 10 years and upgrading to version 2 nine months ago, I will be looking for something to replace it and it won't be from Digital Aquatic. If customer service is too busy or too unconcerned to return phone call requesting assistance I need to spend my dollars elsewhere.


Return to “ReefKeeper Elite (RKE)”

Who is online

Users browsing this forum: No registered users and 1 guest